RSS

Cisco, Home, Jaringan

Fri 2012 at 11:14 am by Yustian M

Untuk menambah artikel pada kategori cisco, kali ini saya akan memberikan tutorial mengenai cara melakukan konfigurasi InterVLAN pada MLS (Multi-Layer Switching) Cisco.  Mungkin sebagian dari anda sudah mengetahui apa sih InterVLAN itu, terlebih apabila anda adalah seorang mahasiswa IT yang telah mendapatkan materi kuliah jaringan.

Wah ternyata artikel saya dikategori ini sangatlah sedikit tepatnya hanya satu artikel :aie: .  Ok langsung saja tanpa basabasi, InterVLAN adalah suatu cara untuk menghubungan jaringan VLAN yang berbeda agar dapat saling berkomunikasi satu sama lainnya. Sedangkan VLAN sediri merupakan suatu teknologi yang terdapat pada suatu switch yang bertujuan untuk mengsegmentasi secara logik jaringan pada switch sehingga dapat membagi jaringan tersebut ke dalam beberapa broadcast domain berbeda. Dengan pembagian broadcast domain ini diharapkan VLAN dapat memberikan efisiensi penggunaan bandwidth, performance, fleksibilitas dan keamanan pada suatu jaringan.  Terdapat beberapa cara untuk melakukan InterVLAN diantaranya sebagai berikut.

  • ROAS (Router on a Stick)/Traditional InterVLAN, cara ini yang sering diperkenal pada materi CCNA pada CNAP (Cisco Network Academy Program), dimana untuk menghubungkan VLAN pada L2 switch yang berbeda diperlukan suatu perangkat Layer 3 OSI model seperti Router.  Pada cara ini port pada switch yang terhubung langsung pada router haruslah menggunakan mode Trunk dan pada interface router yang terhubung ke swicth dibuat beberapa subinterface dan ip address berserta jenis encapsulationnya sesuai dengan jumlah VLAN yang ingin dihubungkan. Nah kali ini saya tidak akan menggunakan cara ini karena ROAS sudah sangatlah umum ditemui pada materi-materi jaringan komputer terutama CNAP.
  • Swicth Layer 3/MLS, cara ini mencoba menggunakan switch teknologi terbaru yang saat ini telah dapat menggabungkan switch dengan beberapa fungsi utama dari perangkat Layer 3 OSI model untuk menghubungakan jaringan yang berbeda dan mencari jalur terbaik dalam pengiriman paket data ke perangkat tujuan. Tujuan penggunaan MLS adalah untuk meningkatkan kinerja komunikasi antar segmen dengan latensi rendah pada jaringan multi-segmen berkecapatan tinggi sehinnga dapat menghidari bottleneck routing.

Dalam tutorial kali ini saya akan membuat 2 skenario dalam mengimplementasikan InterVLAN pada MPS berdasarkan studi kasus sederhana berikut ini:

  • 1. Buat 3 group jaringan menggunakan 9 host dan 2 switch MLS dengan minimal 2 host pada setiap groupnya.
  • 2. Pastikan setiap host pada 1 group dapat saling berkomunikasi.
  • 3. Pastikan setiap host pada suatu group dapat saling berkomunikasi dengan host pada group yang lainnya.

Skenario 1

Inter-Vlan L3 Switch

Bila anda mengerti dengan skema topology jaringan diatas,  silahkan ikuti langkah berikutnya :ciao:  :

Tahap Konfigurasi


SwitchA#configure terminal

SwitchA(config)#vlan 2

SwitchA(config-vlan)#name "Group 1"

SwitchA(config-vlan)#exit

SwitchA(config)#vlan 3

SwitchA(config-vlan)#name "Group 2"

SwitchA(config-vlan)#exit

SwitchA(config)#vlan 3

SwitchA(config-vlan)#name "Group 3"

SwitchA(config-vlan)#exit

SwitchA(config)#interface fa0/2

SwitchA(config-if)#switchport mode access

SwitchA(config-if)#switchport access vlan 2

SwitchA(config-if)#interface range fa0/3-4

SwitchA(config-if)#switchport mode access

SwitchA(config-if)#switchport access vlan 3

SwitchA(config-if)#interface fa0/5

SwitchA(config-if)#switchport mode access

SwitchA(config-if)#switchport access vlan 4

SwitchA(config-if)#interface fa0/1

SwitchA(config-if)#switchport mode trunk

SwitchA(config-if)#switchport trunk encapsulation dot1q

SwitchA(config-if)#interface vlan 2

SwitchA(config-if)#ip address 192.168.2.1 255.255.255.0

SwitchA(config-if)#interface vlan 3

SwitchA(config-if)#ip address 192.168.3.1 255.255.255.0

SwitchA(config-if)#interface vlan 4

SwitchA(config-if)#ip address 192.168.4.1 255.255.255.0

SwitchA(config-if)#exit

SwitchA(config)#ip routing

Untuk konfigurasi SwitchB dapat dengan menggunakan perintah-perintah yang sama dengan pada Swicth atau dengan membuat VTP dengan SwicthA sebagai mode server dan SwitchB pada mode client sehingga mempercepat pembuatan VLAN yang sama. Dari konfigurasi diatas terdapat beberapa hal penting diantaranya:

  • 1. Trunk, berfungsi untuk menyediakan akses komunikasi antar VLAN yang sama pada switch yang berbeda-beda.
  • 2. Interface Vlan, perintah ini hanya terdapat pada MLS  yang berfungsi sebagai gateway dari suatu VLAN untuk menuju ke VLAN yang lainnya.
  • 3. IP Routing, perintah ini untuk mengaktifkan fungsi routing pada MLS sehingga dapat meneruskan paket data dari suatu interface gateway yang satu ke interface gateway yang lainnya.

Bila anda telah melakukan konfigurasi dengan benar maka silahkan masuk pada tahap ujicoba.

Switch#config t
Switch(config)#vlan 10

Switch(config)#vlan 20

Tahap Ujicoba

  • 1. Ping antar host dalam satu group vlan. Contoh ping dari host pada group 1  dengan ip 192.168.2.2 ke host ip 192.168.2.3
  • 2. Ping ke host lain pada group vlan yang berberda. Contoh ping dari host group 1 dengan ip 192.168.2.2 ke host 192.168.4.3 pada group 3

Bila kedua ujicoba RTO, silahkan periksa kembali topology, ip atau konfigurasi anda.  Bila berhasil replay dan masih ingin oprek silahkan masuk pada skenario 2.

Skenario 2

Inter-Vlan L3 Switch2

Bila anda mengerti dengan skema topology jaringan diatas,  silahkan ikuti langkah berikutnya :ciao:  :

Tahap Konfigurasi

SwicthA


SwitchA#configure terminal

SwitchA(config)#vlan 2

SwitchA(config-vlan)#name "Group 1"

SwitchA(config-vlan)#exit

SwitchA(config)#vlan 3

SwitchA(config-vlan)#name "Group 2"

SwitchA(config-vlan)#exit

SwitchA(config)#interface range fa0/2-3

SwitchA(config-if)#switchport mode access

SwitchA(config-if)#switchport access vlan 2

SwitchA(config-if)#interface range fa0/4-5

SwitchA(config-if)#switchport mode access

SwitchA(config-if)#switchport access vlan 3

SwitchA(config-if)#interface fa0/1

SwitchA(config-if)#no switchport

SwitchA(config-if)#ip address 192.168.1.1  255.255.255.252

SwitchA(config-if)#interface vlan 2

SwitchA(config-if)#ip address 192.168.2.1 255.255.255.0

SwitchA(config-if)#interface vlan 3

SwitchA(config-if)#ip address 192.168.3.1 255.255.255.0

SwitchA(config-if)#exit

SwitchA(config)#ip routing

SwitchA(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2

SwicthB


SwitchB#configure terminal

SwitchB(config)#vlan 4

SwitchB(config-vlan)#name "Group 3"

SwitchB(config-vlan)#exit

SwitchB(config)#interface range fa0/2-6

SwitchB(config-if)#switchport mode access

SwitchB(config-if)#switchport access vlan 4

SwitchB(config-if)#interface fa0/1

SwitchB(config-if)#no switchport

SwitchB(config-if)#ip address 192.168.1.2  255.255.255.252

SwitchB(config-if)#interface vlan 4

SwitchB(config-if)#ip address 192.168.4.1 255.255.255.0

SwitchB(config-if)#exit

SwitchB(config)#ip routing

SwitchB(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

Dari konfigurasi diatas terdapat beberapa hal penting diantaranya:

  • 1. No Swicthport, pada skenario ini tidak lagi diperlukan trunking karena setiap switch tidak memiliki VLAN yang sama pada setiap switch sehingga untuk meneruskan paket data dari antar VLAN pada switch diperlukan ip address nexthop yang digunakan pada saat routing.
  • 2. Interface Vlan, perintah ini hanya terdapat pada MLS  yang berfungsi sebagai gateway dari suatu VLAN untuk menuju ke VLAN yang lainnya.
  • 3. IP Routing, perintah ini untuk mengaktifkan fungsi routing pada MLS sehingga dapat meneruskan paket data dari suatu interface gateway yang satu ke interface gateway yang lainnya.
  • 4. IP Route Default, perintah ini untuk menentukan kemana paket data akan diteruskan bila network dari host tujuan tidak terdapat pada interface switch.

Bila anda telah melakukan konfigurasi dengan benar maka silahkan masuk pada tahap ujicoba.

Switch#config t
Switch(config)#vlan 10

Switch(config)#vlan 20

Tahap Ujicoba

  • 1. Ping antar host dalam satu group vlan. Contoh ping dari host pada group 1  dengan ip 192.168.2.2 ke host ip 192.168.2.3
  • 2. Ping ke host lain pada group vlan yang berberda. Contoh ping dari host group 1 dengan ip 192.168.2.2 ke host 192.168.4.2 pada group 3

Bila kedua ujicoba RTO, silahkan periksa kembali topology, ip atau konfigurasi anda.

Demikianlah tutorial saya kali ini . Dan untuk tutorial saya selanjutnya akan lebih membahas ke studi kasus yang tidak dijelaskan pada CNAP baik CCNA ataupun CCNP. Terima kasih.

, , , , , , ,

This post was written by:

- who has written 61 posts on Yustian Blog.

Artikel ini dapat disebar,dimodifikasi,dicopy dan digunakan sebagaimana semestinya. Dengan menyantumkan nama dan referensi asli. Dan bila ingin berlangganan berita dan artikel diblog ini silahkan Subscribe ke RSS Feed Yustian Blog dan Email Subscription Request

Contact the author

Leave a Reply

:p 8) :lol: =( :8 ;) :(( :o: :[ :) :D :-| :bloody: :cool: :choler: :love: :oups: :aie: :beurk: :canny: :go: :miam: :ueue: :nose: :oh: :oups2: :prud: :yo: :sadd: :bloody2: :cache: :rose: :sure: :dream: :neo: :yes: :sweat: :kiss: :creve: :what: :pff: :hm: :bobo: :ciao: :dribble: :gene: